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Purpose

The purpose of this user guide is to introduce the basic functions of PixelWrench2 to all users, 
especially first-time users. As such, this guide is not intended to be comprehensive; rather, it is written 
in a straight-forward, step-by-step way, so that users can familiarize themselves with the software and 
be better equipped to handle more specific, advanced features of the software as the need arises.

This user guide is also set up to help users access it efficiently: the Table of Contents contains 
hyperlinks to all the sections, and the top right of the header of this document contains a hyperlink back
to the Table of Contents.

If you have any specific questions about PixelWrench2 not covered in this guide, please refer
to the PixelWrench Help section under the Help menu of the software or email 
support@tetracam.com. You can also access specific sections of the PixelWrench Help by
clicking the blue question mark in most windows of the software, and you can refer to the 
PixelWrench2 FAQ located on our website.

If you would like to provide feedback regarding this user guide, feel free to email 
support@tetracam.com.

Prerequisites to Using PixelWrench2

System Requirements

The system requirements of PixelWrench2 are the following:

Any Microsoft Windows 32 bit or 64 bit operating system that has Microsoft .NET Framework 3.5 
installed. You can retrieve Microsoft .NET Framework 3.5 from your installation CD included with 
your camera system or by searching for it online, if it isn’t installed on your computer already.

The latest version of PixelWrench2 is always available here: http://tetracam.com/PWversion.htm 
Please be sure to have the latest version of PixelWrench2 installed on your computer; PixelWrench2 is 
updated continually at that URL. You can also check for updates by clicking the Help menu in 
PixelWrench2 and clicking Check for Updates.
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How to Install PixelWrench2

Setup Procedure

The process for installing PixelWrench2 is straight-forward. The following illustrates the process:

1. Insert the Tetracam installation CD that came with your camera system into your PC’s CD/DVD
drive.

2. If you have a 32 bit PC, open the PW2_x32 folder; otherwise, open the PW2_x64 folder.

3. Double-click the setup.exe file.

4. Click Next in the first window that appears.

5. After choosing what users you want to install PixelWrench2 for, click Next.
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6. Click Next to start the installation.

7. A dialog box will appear asking for Administrator permission to continue. Click Yes on this box.

8. Click Close when the installation is completed.

Copying Your CPF or MCA File to the Support Folder

In addition to the process illustrated above, Tetracam recommends, at this point, to copy the CPF or 
MCA file from your Tetracam installation CD to the Support folder of the PixelWrench2 directory that 
was created during the installation. To do so, follow this procedure:

1. If you have installed PixelWrench2 in the default directory and your system architecture 
matches the version you installed, it is located at C:\Program Files\Tetracam\PixelWrench2. 
However, if you have a 64 bit PC and you installed the 32 bit version of PixelWrench2, the 
default directory is C:\Program Files (x86)\Tetracam\PixelWrench2.

2. Open a Windows Explorer window, and click on the Address Bar of the window. 

3. Copy and paste the PixelWrench2 directory address into the Address Bar, and press Enter on 
your keyboard.

4. Now, double-click the Support folder now that you are in the PixelWrench2 directory. Keep this
window open.

5. With your Tetracam installation CD inserted, open another Windows Explorer window. In this 
window, navigate to the CD/DVD directory. Inside the root folder of this directory, there is 
either a CPF or MCA file, depending on whether you have an ADC or MCA series system.
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6. Now, copy and paste the CPF or MCA file into the Support folder.

Instructions for ADC Series Systems

Transfer Images and Logs Using GPS Log Distiller

After you’ve taken several pictures with your camera (with or without logging turned on), you’ll want 
to extract those pictures (and logs) into a folder on your PC by using either GPS Log Distiller or 
Windows Explorer. Tetracam recommends accessing the image files from your camera by using a 
memory card reader. Tetracam also recommends using GPS Log Distiller for file transfers. The 
following illustrates how to extract image and log files from a memory card reader using GPS Log 
Distiller:

1. Open PixelWrench2.

2. Insert your memory card reader that contains the memory card of your camera.

3. Click the View menu, and then click Launch GPS Distiller.

4. Click the Transfer Files button in the GPS Log Distiller window that opens.

5. Next, choose or create a directory you would like to save the files to. When you’ve selected 
your desired directory, click OK.

6. Once the transfer is done, optionally erase the card using the Erase Camera button, then unplug 
your memory card reader.
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Information About CPF Files and Opening Them

Once you’ve transferred your RAW or RWS files to your PC, you’ll want to make sure that you’ve 
opened a CPF file. You can acquire a CPF file from two different sources:

1. Your factory CPF file in your Support folder referring to this section that comes from the 
installation CD associated with your camera named XXXXXX.cpf, where XXXXXX matches 
the serial number of your camera.

2. The CPF file that you generated in the field that pertains to the specific conditions that you were
taking pictures in using a neutral reflectance standard target.

For information on making your own CPF file to increase accuracy of measurements, click
the blue question mark in the Matrix tab of the Index Tools form to reach the right section in
the PixelWrench Help; in addition, you can reach the PixelWrench Help by opening the Help
menu of the software. For information about calibration, please refer to the same area just
mentioned as well as the PixelWrench2 FAQ.

Note: Making a CPF file in the Matrix tab and using the Calibrate button in the Index tab, both in the 
Index Tools form, follow different procedures: The Calibrate button requires a color processed 
NIR/R/G image, while making a CPF file requires a RAW or RWS image. Further, a CPF file is used to
increase the measurement accuracy of both color processing as well as generating vegetation indices, 
while the Calibrate button is only used to increase the measurement accuracy of generating vegetation 
indices.

It is highly recommended to open a CPF file that is not one of the default CPF files located in the 
Support folder of PixelWrench2 to ensure more accurate measurements; instead, open your factory 
CPF file that you copied into the Support folder referring to this section or the CPF file you created 
yourself.

To open a CPF file, perform the following:

1. With PixelWrench2 open, click the View
menu, and then click Index Tools.

2. Next, in the Matrix tab, click Open CPF.

3. Then, navigate to your CPF file located
either in the Support folder or elsewhere.
Once you’ve done that, click Open.
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Using the Index Tab of Index Tools to Create Individual Color Processed Image Files

Now that you have your RAW or RWS files on your PC and you have your CPF file opened, you are 
ready to create your color processed NIR/R/G image files. The following is the procedure for color 
processing one RAW or RWS file at a time:

1. Open Index Tools from the View menu of PixelWrench2, if it is not already opened.

2. Click the Index tab.

3. Now, click the File menu of PixelWrench2 and then click Open.

4. There is a drop down menu above the Open and Cancel buttons. Click on that, and choose 
*.DCM, *.RAW, *.RWS from that menu.

5. Navigate to the directory that contains your RAW or
RWS files.

6. Select one of the files, and press Open.

7. Now that your RAW or RWS file is opened, click on
the drop down menu right below all of the tabs in the
Index Tools form. Select Color Process Raw Image
from that menu.

8. Click Execute.

9. Now you should see your color processed RAW or RWS image in view.
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Using the Batch Tab of Index Tools to Create Many Color Processed Image Files

The process for creating many color processed image files at once is as follows:

1. Open Index Tools from PixelWrench2 if it is not already opened.

2. Click on the Batch tab.

3. There are many different image types to choose from. Click on the Save Originals check box; 
leave all other check boxes unchecked.

4. Where it says “Save batch files to:”, there is a drop down selector. Click on this and a file 
format of your choice, such as TIF.

5. Click on the Run Folder Batch button.

6. A window has opened. At this point, you’ll want to select the folder that you put your RAW or 
RWS files in on your PC. Once you have done so, click OK.

7. Now you want to select or create a folder to put the color processed image files into. Once you 
have done so, click OK.

8. At this point, PixelWrench2 will create all of your color processed image files; it may take a 
while if you have a lot of RAW or RWS files. Once the process finishes, you’ve successfully 
created your color processed NIR/R/G image files!
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Instructions for MCA Series Systems

Transfer Images and Logs Using GPS Log Distiller

After you’ve taken several pictures (with or without logging turned on) with your camera system, 
you’ll want to extract those pictures (and logs) into a folder by using GPS Log Distiller. Using 
Windows Explorer is too inconvenient in contrast to this utility when working with MCA series 
systems. The following illustrates how to extract image and log files from USB using GPS Log 
Distiller:

1. Open PixelWrench2.

2. Click the View menu, and then click Launch GPS Distiller.

3. Plug in your camera system via USB, then press the Info button in the GPS Log Distiller 
window.

4. Click the Transfer Files button.

5. Next, choose or create a directory you would like to save the files. When you’ve selected your 
desired directory, click OK.

6. Once the transfer is done, optionally erase your camera system by clicking the Erase Camera 
button. The GPS Log Distiller window will indicate when this process is finished.

7. Wait a few seconds, unplug your camera system from USB, and then power it off.
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Loading Your MCA Alignment File

In order for all of the image files in the MCA to be aligned precisely for each picture that was taken, 
you must use the MCA alignment file associated with your specific camera system. This file is located 
in the Support folder of the PixelWrench2 directory, which you copied from your Tetracam installation 
CD in this   section. The following describes the process of loading your MCA alignment file using 
PixelWrench2:

1. Open PixelWrench2, if it isn’t open already.

2. Click on the View menu, then click Index Tools.

3. Click on the MCA tab.

4. Now, click Open MCA.

5. Navigate to the Support folder of the PixelWrench2 directory.

6. Click your MCA file, and click Open.
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Creating Multi-Page TIF Image Files

Once you’ve loaded your MCA file and you’ve acquired RAW or RWS image files, you are now ready 
to export multi-page TIF image files from your RAW or RWS image files. The process consists of the 
following:

1. Open Index Tools from PixelWrench2, if you haven’t already.

2. Click the MCA tab.

3. Open your MCA alignment file, if you haven’t already, referring to this section.

4. If you have an MCA system that is   not   a Snap system, be sure to check the box next to Equalize
Pixel Gains. Do not check any other boxes, unless you have a specific reason to do so.

5. In the big text box that was populated by your MCA alignment file, if you see any line that 
mentions ILS, put an ‘x’ (without quotes) in front of that line.

6. Click the Multipage Tifs button to the right of “Save RAW, RWS sets as”. 

7. In the window that pops up, navigate to the folder that contains all of your RAW or RWS image
files. Once you have done so, click OK.

8. In the next window, navigate to or create a folder that you’d like to output the multi-page TIF 
image files to. Once you have done so, click OK.

9. The process of creating the multi-page TIF image files may take a while depending on how 
many RAW or RWS files you are working with. Once the process is complete, you now have 
your multi-page TIF image files!
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Creating RGB Extractions of Multi-Page TIF Image Files

After you have created multi-page TIF image files, you may want to create RGB extractions of those 
files. Here is the process:

1. Open Index Tools from PixelWrench2 and click on the MCA tab.

2. Click on the File menu, and then click Open.

3. In the window that pops up, navigate to the folder of the multi-page TIF image files you created
in the previous section. Select one of them, and click Open.

4. You should see a window with the image file in view, at this point. Now, in the Index Tools 
form in the MCA tab, there are three drop downs underneath “Active File”. In these drop 
downs, you are able to select the wavelengths to be displayed with red, green, and blue. A 
typical choice is NIR (800 nm) on the red bitplane, red (680 nm) on the green bitplane, and 
green (550 nm) on the blue bitplane; if you have an RGB+3 system, you’d want to put red on 
the red bitplane, green on the green bitplane, and blue on the blue bitplane, for example. Once 
you’ve chosen what wavelengths you wish to display, you can either create individual RGB 
extractions from files that are opened in PixelWrench2 or create multiple RGB extractions from
a folder of multi-page TIF image files. 

5. If you would like to create an RGB extraction from the file that you opened in Step 3, click the 
MultiFrame Tif > RGB button. After you do so, a new window will open displaying your RGB 
extraction!

6. If you want to create multiple RGB extractions from a folder that contains your multi-page TIF 
image files, click the drop down to the right of the Batch > RGB button and select the file 
format of your choice, such as TIF.

7. Click the Batch > RGB button. A window will display asking you for the source folder; 
navigate to the folder that contains your multi-page TIF image files. After you’ve selected that 
folder, press OK.

8. Another window will display; navigate to the folder that you’d like your RGB extraction image 
files to be written to. Once you’ve selected that folder, press OK.

9. Once the process is completed, you’ve successfully created multiple RGB extractions of your 
multi-page TIF image files!
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How to Generate Vegetation Indices Using the Index Tab of Index Tools

On many occasions, using PixelWrench2 to generate vegetation indices is very useful. Note that the 
Pallette tab allows you to customize the display of the vegetation index you choose. The following 
explains how to generate a vegetation index from an image in view:

1. Click on the File menu of PixelWrench2, and then click Open.

2. Navigate to a folder that contains either color processed image files (ADC Series) or RGB 
extractions (MCA Series).

3. Click on the desired file, then press Open.

4. Now, click on the View menu, and then click on 
Index Tools.

5. Click on the Index tab, if it isn’t already active.

6. There’s a drop down menu right below all of the
tabs of the Index Tools form. Select one of the
indices from the menu, such as NDVI.

7. Now, click Execute.

8. A window will now appear of the vegetation index you chose!
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How to Acquire a GPS Log File

If your camera system has logging turned on either by using the built-in camera menu or GPS Log 
Distiller, your system will create a log file that corresponds with images taken; using this log file, a 
GPS log file can be created using GPS Log Distiller. The following explains how to use GPS Log 
Distiller to generate GPS log files:

1. Transfer images and logs from your camera system to a folder of your choice. If you forgot how
to do this, follow one of these links, depending on your system: ADC series system, MCA series
system.

2. Click Distill Logs.

3. In the window that appears, select the folder that contains the images and logs that you 
transferred to in Step 1.

4. Once the process is completed, you will have a display of what was produced in the GPS Log 
Distiller window in addition to a GPS file, which was placed in the source folder you chose.

Conclusion

Please feel free to email support@tetracam.com with your comments, suggestions, questions, or 
general feedback about this guide. Once again, be sure to keep PixelWrench2 updated by clicking 
Check for Updates in the Help menu of the software or by visiting  http://tetracam.com/PWversion.htm

In addition, check for general updates regarding Tetracam by visiting http://tetracam.com/

Lastly, thank you for using this user guide. 
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